using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{""id"":""auth_payer_8gtx3241241UH0Y29zP7D931""}";
string input = @"""\r\n```\n[\r\n {\r\n \""tactic\"": \""targeting\"",\r\n \""targeting\"": \""s=1167891 OR s=455871 OR s=455878 OR s=455872 OR s=455873 OR s=455874 OR s=455875 OR s=455876 OR s=455877 OR s=2077 OR s=110598 OR s=261857 OR s=4647 OR s=2042 OR s=2039 OR s=691 OR s=1398 OR s=447247 OR s=428051 OR s=446928 OR s=447359 OR s=225461 OR s=225618 OR s=447527 OR s=447486 OR s=446609 OR s=446767 OR s=447170 OR s=1442 OR s=1421 OR s=3894 OR s=261852 OR s=262377 OR s=633295 OR s=633274 OR s=633286 OR s=633288 OR s=633273 OR s=743155 OR s=743167 OR s=743207 OR s=743149 OR s=743162 OR s=739645\""\r\n }\r\n]""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}