$re = '/^(.+?\/).+\/(.+)$/m';
$str = 'path1/path2/../path3
path1/./path2';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;