re = /(https?:\/\/)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()!@:%_\+.~#?&\/=]*)/m
str = 'https://subdomain.domain.tld/foo/bar?query#fragment
google.com
something.something.tld
foo.bar.baz.qux.corge.grault'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end