#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^\*{2}Header2\*{2} *\n((?:(?!^\*{2}[^*]*\*{2}).)*?)(?=\s*^\*{2}[^*]*\*{2}|\s*\Z)"
Local $sString = "**Header1** " & @CRLF & _
"thing1 " & @CRLF & _
"thing2 " & @CRLF & _
"thing3 " & @CRLF & _
"thing4 " & @CRLF & _
"" & @CRLF & _
"**Header2** " & @CRLF & _
"dsfgs " & @CRLF & _
"sdgsg " & @CRLF & _
"rrrrrr " & @CRLF & _
"" & @CRLF & _
"**Hello Dolly** " & @CRLF & _
"abider " & @CRLF & _
"abcder " & @CRLF & _
"ffffff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")