const regex = new RegExp('^(?P<operating_fluid>M)(?P<sep_1>-)(?P<unit_type>SR)(?P<unit_size>\\d{1,2})(?P<mounting_type>K)(?P<unit_design>E|D)(?P<cracking_pressure>\\d{1,3})(?P<sep_2>-)(?P<unit_series>1X)(?P<sep_3>/)(?P<seal_material>V|)(?P<additional_details>(.|[0-9])*)$
', 'gm')
const str = `M-SR6KD05-1X/
M-SR8KD05-1X/
M-SR10KD05-1X/
M-SR20KD05-1X/
M-SR25KD05-1X/
M-SR30KD05-1X/
M-SR6KD15-1X/
M-SR8KD15-1X/
M-SR10KD15-1X/
M-SR20KD15-1X/
M-SR25KD15-1X/
M-SR30KD15-1X/
M-SR6KD30-1X/
M-SR8KD30-1X/
M-SR10KD30-1X/
M-SR20KD30-1X/
M-SR25KD30-1X/
M-SR30KD30-1X/
M-SR6KD02-1X/
M-SR8KD02-1X/
M-SR20KD02-1X/
M-SR25KD02-1X/
M-SR30KD02-1X/
M-SR10KD50-1X/
M-SR20KD50-1X/
M-SR25KD50-1X/
M-SR30KD50-1X/
M-SR10KD02-1X/
M-SR6KD50-1X/
M-SR10KD05-1X/B12
M-SR8KD05-1X/B06
M-SR30KD00-1X/
M-SR20KE05-1X/VSO13
M-SR20KE05-1X/
M-SR10KE05-1X/
M-SR25KE05-1X/
M-SR30KE05-1X/
M-SR15KE05-1X/
M-SR30KE02-1X/
M-SR20KE02-1X/
M-SR10KE02-1X/
M-SR30KE30-1X/
M-SR15KE30-1X/
M-SR8KE05-1X/
M-SR10KE50-1X/V
M-SR25KE30-1X/
M-SR20KE30-1X/
M-SR10KE15-1X/
M-SR15KE15-1X/
M-SR20KE15-1X/
M-SR10KE30-1X/
M-SR8KE15-1X/
M-SR20KE50-1X/
M-SR8KE30-1X/
M-SR25KE15-1X/
M-SR10KE05-1X/V
M-SR30KE15-1X/
M-SR20KE15-1X/V
M-SR15KE50-1X/
M-SR15KE02-1X/
M-SR30KE50-1X/
M-SR15KE05-1X/V
M-SR20KE05-1X/V
M-SR30KE50-1X/V
M-SR30KE05-1X/V
M-SR20KE00-1X/
M-SR25KE50-1X/
M-SR30KE00-1X/
M-SR8KE50-1X/
M-SR10KE00-1X/
M-SR25KE50-1X/V
M-SR30KE30-1X/V
M-SR30KE02-1X/V
M-SR8KE02-1X/
M-SR25KE05-1X/V
M-SR8KE05-1X/V
M-SR25KE02-1X/
M-SR15KE00-1X/
M-SR8KE02-1X/V
M-SR15KE50-1X/V
M-SR8KE00-1X/
M-SR10KE50-1X/
M-SR25KE00-1X/
M-SR8KE05-1X/SO1
M-SR8KE00-1X/V
M-SR10KE02-1X/V
M-SR20KE02-1X/V
M-SR30KE15-1X/V
M-SR10KE30-1X/V
M-SR15KE30-1X/V
M-SR20KE00-1X/V
M-SR25KE30-1X/V
M-SR15KE15-1X/V
M-SR15KE02-1X/V
M-SR20KE05-1X/MT
M-SR8KE15-1X/V
M-SR25KE50-1X/SO6
M-SR25KE00-1X/V
M-SR15KE00-1X/V
M-SR20KE30-1X/V
M-SR20KE05-1X/SO1
M-SR10KE15-1X/V
M-SR8KE05-1X/VSO1
M-SR8KE50-1X/V
M-SR20KE50-1X/V
M-SR8KE05-1X/SO11
M-SR15KE05-1X/MT
M-SR10KE05-1X/SO1
M-SR8KE05-1X/MT
M-SR15KE05-1X/SO1
M-SR8KE30-1X/V
M-SR10KE00-1X/V
M-SR25KE15-1X/V
M-SR30KE00-1X/V
M-SR15KE05-1X/SO13
M-SR8KE05-1X/SO14
M-SR10KE02-1X/SO1
M-SR20KE15-1X/MT
M-SR15KE05-1X/SO18
M-SR25KE05-1X/SO11
M-SR8KE02-1X/SO11
M-SR8KE02-1X/SO1
M-SR10KE50-1X/MT
M-SR30KE30-1X/MT
M-SR30KE05-1X/MT
M-SR25KE02-1X/V
M-SR25KE05-1X/MT
M-SR15KE30-1X/MT
M-SR30KE05-1X/SO11
M-SR20KE02-1X/MT
M-SR10KE02-1X/SO14
M-SR10KE05-1X/MT
M-SR15KE50-1X/SO11
M-SR8KE02-1X/VSO11
M-SR8KE02-1X/VSO1
M-SR30KE50-1X/SO11
M-SR25KE50-1X/SO11
M-SR20KE05-1X/SO11
M-SR10KE05-1X/VSO11
M-SR8KE02-1X/MT
M-SR8KE50-1X/MT
M-SR25KE15-1X/MT
M-SR15KE50-1X/MT
M-SR20KE30-1X/MT
M-SR25KE30-1X/MT
M-SR30KE30-1X/SO14
M-SR30KE120-1X/SO28
M-SR30KE60-1X/MT
M-SR10KE01-1X/
M-SR15KE01-1X/
M-SR8KE01-1X/
M-SR30KE01-1X/
M-SR25KE01-1X/
M-SR20KE01-1X/
M-SR30KE120-1X/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}