package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?<IPv4_dec_octet>[0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])\.){3,3}(?<IPv4_dec_octet_end>[0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])`)
var str = `1.2.256.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}