re = /(?P<mount>rockcut\/aws)\/(?P<meta>data)?\/(?P<env>(dev|test|stage|prod))?\/(?P<app>\w+)?\/?(?P<team>\w+)?/m
str = 'rockcut/aws/data/dev/someapp/s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end