re = /[^\s]{4,}/m
str = 'images/1x/1083bce6__color_272x92dp.png 1x, images/2x/b3716cd2_color_272x92dp.png 2x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end