$re = '/.+?(?:\s\[.+\])?/m';
$str = 'First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);