$re = '/\W/u';
$str = 'aaaaaaaaaaaaaaa ds sd日本語 ไทย 中文 عربى';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);