#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=Nokia.*|Oppo.*|Huawei.*|Xiaomi.*).*"
Local $sString = "iPhone 7 Plus" & @CRLF & _
"iPad Pro 12.9 2015 iOS15.5 beta 4" & @CRLF & _
"Xiaomi Pocophone F1" & @CRLF & _
"Google Pixel 4 XL" & @CRLF & _
"Samsung Galaxy S22 Plus 5G" & @CRLF & _
"Samsung Galaxy Tab A 9.7" & @CRLF & _
"iPhone 11 Pro iOS15.5 beta4" & @CRLF & _
"iPad Pro 10.5 2017" & @CRLF & _
"Samsung Tab E" & @CRLF & _
"Huawei Y9 2019" & @CRLF & _
"iPad 9.7 2018 iOS15.5 beta4" & @CRLF & _
"Samsung Galaxy Tab S8" & @CRLF & _
"iPhone X " & @CRLF & _
"iPhone 11 Pro Max" & @CRLF & _
"Samsung Tab E 9.6" & @CRLF & _
"Samsung Galaxy S8" & @CRLF & _
"Google Pixel 2" & @CRLF & _
"Samsung Galaxy A10" & @CRLF & _
"Samsung Galaxy A51" & @CRLF & _
"LG Q6" & @CRLF & _
"Huawei P9" & @CRLF & _
"iPad Pro 10.5 2017" & @CRLF & _
"Samsung Galaxy A71 5G" & @CRLF & _
"ZTE Axon 7" & @CRLF & _
"iPad mini 3" & @CRLF & _
"iPhone X" & @CRLF & _
"Samsung Galaxy S20 Ultra" & @CRLF & _
"2iPad Pro 12.9 2021" & @CRLF & _
"LG Q Stylo 4" & @CRLF & _
"Moto Z2 Force" & @CRLF & _
"Samsung Galaxy S21 5G" & @CRLF & _
"iPhone 13" & @CRLF & _
"ZTE Axon 7" & @CRLF & _
"Google Pixel 3a XL" & @CRLF & _
"Samsung Galaxy S6 Edge" & @CRLF & _
"iPhone 11" & @CRLF & _
"iPhone 12 mini" & @CRLF & _
"Sony Xperia XZ" & @CRLF & _
"iPad Pro 12.9 2018" & @CRLF & _
"OnePlus 9 Pro" & @CRLF & _
"Samsung Galaxy S8+" & @CRLF & _
"iPad Pro 11 2018" & @CRLF & _
"iPhone 12" & @CRLF & _
"Samsung Galaxy Note 20 Ultra 5G" & @CRLF & _
"LG V30" & @CRLF & _
"Motorola Moto Z" & @CRLF & _
"OnePlus 5T" & @CRLF & _
"Samsung Galaxy S6 Edge" & @CRLF & _
"Samsung Galaxy M20" & @CRLF & _
"OnePlus 9" & @CRLF & _
"iPhone X iOS15.5 beta4" & @CRLF & _
"Samsung Galaxy A02" & @CRLF & _
"iPad Air 2" & @CRLF & _
"Samsung Galaxy S7" & @CRLF & _
"iPhone 8" & @CRLF & _
"Mason D450B" & @CRLF & _
"iPhone 6" & @CRLF & _
"iPhone XS Max" & @CRLF & _
"iPad mini 4" & @CRLF & _
"Samsung Galaxy S22 5G" & @CRLF & _
"iPad Air 3 (2019)" & @CRLF & _
"Google Pixel 4a" & @CRLF & _
"Samsung Galaxy Tab A 10.1 2016" & @CRLF & _
"Samsung Galaxy Note 8" & @CRLF & _
"iPhone SE 2020" & @CRLF & _
"Asus Google Nexus 7 (2013)" & @CRLF & _
"iPhone 11 Pro" & @CRLF & _
"Samsung Galaxy A30" & @CRLF & _
"Google Pixel 4 XL" & @CRLF & _
"iPhone 12 Pro" & @CRLF & _
"iPad Mini 2019" & @CRLF & _
"Vivo X21" & @CRLF & _
"iPad 9.7 2018" & @CRLF & _
"iPad 10.2 2020" & @CRLF & _
"Samsung Galaxy S10e" & @CRLF & _
"iPhone SE" & @CRLF & _
"iPad Air 2" & @CRLF & _
"iPad Air 2022 5th Gen" & @CRLF & _
"iPad Air 2020" & @CRLF & _
"Samsung Galaxy S10" & @CRLF & _
"Samsung Galaxy S21 Plus 5G" & @CRLF & _
"OnePlus Nord N200 5G" & @CRLF & _
"iPad Air 2" & @CRLF & _
"Google Pixel 4 XL" & @CRLF & _
"Samsung Galaxy A9 2018" & @CRLF & _
"Samsung Galaxy A51" & @CRLF & _
"Motorola Moto G Stylus 2021" & @CRLF & _
"Google Pixel 4" & @CRLF & _
"Huawei Honor 9" & @CRLF & _
"Samsung Galaxy S6 Edge+" & @CRLF & _
"Samsung Galaxy A20e" & @CRLF & _
"iPad Pro 11 2021" & @CRLF & _
"iPhone SE 2020" & @CRLF & _
"Mason G450A1" & @CRLF & _
"Xiaomi Mi MIX 2" & @CRLF & _
"Samsung Galaxy Tab A7" & @CRLF & _
"iPhone 6 Plus" & @CRLF & _
"iPad Pro 11 2020" & @CRLF & _
"iPad 10.2 2020" & @CRLF & _
"Google Pixel 5a" & @CRLF & _
"Google Pixel 6 Pro" & @CRLF & _
"Samsung Galaxy A21" & @CRLF & _
"Samsung Galaxy Note 20 5G" & @CRLF & _
"iPad Pro 10.5 2017" & @CRLF & _
"HTC One A9" & @CRLF & _
"Huawei Honor 8" & @CRLF & _
"Samsung Galaxy S6 Edge+" & @CRLF & _
"Google Pixel 2 XL" & @CRLF & _
"iPad 10.2" & @CRLF & _
"iPhone XR" & @CRLF & _
"Samsung Galaxy S8+" & @CRLF & _
"Nokia 7.1" & @CRLF & _
"Samsung Galaxy S20 Plus" & @CRLF & _
"Samsung Galaxy A3 2017" & @CRLF & _
"LG K10" & @CRLF & _
"HTC Desire 12" & @CRLF & _
"iPad Pro 12.9 2015" & @CRLF & _
"Samsung Galaxy A5 (2017)" & @CRLF & _
"Huawei P30 Lite" & @CRLF & _
"LG V40" & @CRLF & _
"OnePlus 6T" & @CRLF & _
"iPad Pro" & @CRLF & _
"iPad Air 2" & @CRLF & _
"Google Pixel 3 XL" & @CRLF & _
"iPhone 7" & @CRLF & _
"Google Pixel C" & @CRLF & _
"iPad Mini 2021 6th Gen" & @CRLF & _
"Motorola Moto G5 Plus" & @CRLF & _
"iPad Air 2020" & @CRLF & _
"Samsung Galaxy S20" & @CRLF & _
"iPhone 8 Plus" & @CRLF & _
"Samsung Galaxy A31" & @CRLF & _
"Google Pixel 3" & @CRLF & _
"Sony Z5 Premium" & @CRLF & _
"Sony Xperia Z1" & @CRLF & _
"LG Phoenix 2" & @CRLF & _
"iPhone 11" & @CRLF & _
"iPad 9.7 2017 5th Gen" & @CRLF & _
"iPhone XS" & @CRLF & _
"Samsung Galaxy Tab S6" & @CRLF & _
"Samsung Galaxy J7 2016" & @CRLF & _
"Honeywell CK65" & @CRLF & _
"Samsung Galaxy A5" & @CRLF & _
"HTC 10" & @CRLF & _
"iPad Pro 12.9 2020" & @CRLF & _
"Sony Xperia 10" & @CRLF & _
"Google Pixel 3a XL" & @CRLF & _
"iPhone 6S" & @CRLF & _
"Sony Xperia 5" & @CRLF & _
"iPad Air" & @CRLF & _
"Samsung Galaxy A6 2018" & @CRLF & _
"Samsung Galaxy S9" & @CRLF & _
"Samsung Galaxy S5" & @CRLF & _
"Google Pixel XL" & @CRLF & _
"LG G7 Thinq" & @CRLF & _
"Motorola Moto X Play" & @CRLF & _
"Huawei P30 Lite" & @CRLF & _
"iPhone XS Max" & @CRLF & _
"Samsung Galaxy S10+" & @CRLF & _
"Samsung Galaxy Tab S2" & @CRLF & _
"Samsung Galaxy Tab S8 Plus" & @CRLF & _
"iPhone SE 2020" & @CRLF & _
"LG K30" & @CRLF & _
"LG V30+ Thinq" & @CRLF & _
"iPhone_11_Pro" & @CRLF & _
"Samsung Galaxy A80" & @CRLF & _
"OnePlus 3T" & @CRLF & _
"iPhone 5S" & @CRLF & _
"Samsung Galaxy S22 Ultra 5G" & @CRLF & _
"iPhone 8" & @CRLF & _
"iPhone 7 Plus" & @CRLF & _
"iPod Touch 6" & @CRLF & _
"iPad Pro 9.7" & @CRLF & _
"Huawei Mate 9" & @CRLF & _
"Samsung Galaxy Note 20 Ultra 5G" & @CRLF & _
"OnePlus 3" & @CRLF & _
"iPhone 12 mini iOS15.5 beta4" & @CRLF & _
"OnePlus 7 Pro" & @CRLF & _
"Nokia 8" & @CRLF & _
"Samsung Galaxy Z Fold 2 5G" & @CRLF & _
"OnePlus 6" & @CRLF & _
"Samsung Galaxy Tab S5e" & @CRLF & _
"Samsung Galaxy A50" & @CRLF & _
"iPhone X" & @CRLF & _
"iPhone 8" & @CRLF & _
"Samsung Galaxy S21 Ultra 5G" & @CRLF & _
"LG Stylo 6" & @CRLF & _
"Google Pixel 3" & @CRLF & _
"iPhone 6" & @CRLF & _
"iPhone X" & @CRLF & _
"iPhone 13 Pro Max" & @CRLF & _
"iPhone 12 Pro Max" & @CRLF & _
"Sony Xperia Z3 Compact" & @CRLF & _
"Xiaomi MI 6" & @CRLF & _
"LG V20" & @CRLF & _
"iPad Air 2 iOS15.5 beta4" & @CRLF & _
"Google Pixel 5" & @CRLF & _
"Motorola Moto G Power (2021)" & @CRLF & _
"Lenovo Tab 3 Pro" & @CRLF & _
"Motorola Moto G6" & @CRLF & _
"Essential PH-1" & @CRLF & _
"Samsung Galaxy Note 9" & @CRLF & _
"iPhone 6" & @CRLF & _
"iPad mini 4" & @CRLF & _
"Samsung Galaxy S10e" & @CRLF & _
"Samsung Galaxy A8 2018" & @CRLF & _
"Samsung Galaxy A10e" & @CRLF & _
"iPad Pro 11 2018" & @CRLF & _
"iPad Pro 12.9 2015" & @CRLF & _
"Samsung Galaxy Note 5" & @CRLF & _
"Samsung Galaxy Fold 5G" & @CRLF & _
"iPhone XR" & @CRLF & _
"iPhone XS" & @CRLF & _
"Samsung Galaxy Note 4" & @CRLF & _
"Samsung Galaxy S21 5G" & @CRLF & _
"Samsung Galaxy Tab S7" & @CRLF & _
"Motorola One Vision" & @CRLF & _
"Samsung Galaxy Note 10+" & @CRLF & _
"iPhone XR" & @CRLF & _
"LG G8 ThinQ" & @CRLF & _
"Amazon Kindle Fire HD 8" & @CRLF & _
"iPhone 7" & @CRLF & _
"iPad Pro 12.9 2017" & @CRLF & _
"Motorola Moto G7" & @CRLF & _
"Samsung Galaxy Tab S7 Plus" & @CRLF & _
"iPhone 8" & @CRLF & _
"Samsung Galaxy Z Flip" & @CRLF & _
"iPhone 6S" & @CRLF & _
"LG G6" & @CRLF & _
"Samsung Galaxy S7 Edge" & @CRLF & _
"Samsung Galaxy Tab S8 Ultra" & @CRLF & _
"Google Pixel 6 Pro" & @CRLF & _
"Huawei P10" & @CRLF & _
"Huawei P20" & @CRLF & _
"Samsung Galaxy Note 5" & @CRLF & _
"OnePlus 8 Pro" & @CRLF & _
"Amazon Kindle Fire HD 8 (2020)" & @CRLF & _
"Samsung Galaxy S6" & @CRLF & _
"iPad Pro 12.9 2017" & @CRLF & _
"Xiaomi Redmi Note 9" & @CRLF & _
"Motorola Nexus 6" & @CRLF & _
"Motorola Moto G6 Plus" & @CRLF & _
"Vivo V9" & @CRLF & _
"iPad Pro 12.9" & @CRLF & _
"iPhone X " & @CRLF & _
"iPhone 8 Plus" & @CRLF & _
"iPad Air 3 (2019)" & @CRLF & _
"Samsung Galaxy Tab S4" & @CRLF & _
"iPhone 8" & @CRLF & _
"Samsung Galaxy S10" & @CRLF & _
"Motorola Moto X (2nd gen)" & @CRLF & _
"iPhone 12 Pro Max" & @CRLF & _
"Amazon Kindle Fire HD 10 (2019)" & @CRLF & _
"OnePlus 7T" & @CRLF & _
"iPad Pro 12.9 2015" & @CRLF & _
"OnePlus 8" & @CRLF & _
"iPad mini 4" & @CRLF & _
"iPhone 13 mini" & @CRLF & _
"iPad Air 2" & @CRLF & _
"iPhone 13 Pro" & @CRLF & _
"Samsung Galaxy Xcover 3" & @CRLF & _
"Xiaomi Redmi 9" & @CRLF & _
"iPhone 7" & @CRLF & _
"Sony Xperia XZ1" & @CRLF & _
"iPhone XS" & @CRLF & _
"ZTE Blade V7 lite" & @CRLF & _
"Huawei P30 Pro" & @CRLF & _
"iPad 10.2 2021 9th Gen" & @CRLF & _
"Samsung Galaxy Tab S4 10.5" & @CRLF & _
"iPhone SE 2020" & @CRLF & _
"iPod Touch 7" & @CRLF & _
"iPad Air 2" & @CRLF & _
"Google Pixel 6" & @CRLF & _
"Amazon Kindle Fire HD 7" & @CRLF & _
"iPhone 7 Plus" & @CRLF & _
"iPhone SE 2022" & @CRLF & _
"Huawei P20 Pro" & @CRLF & _
"Motorola Moto Z Play" & @CRLF & _
"Huawei Mate 10 Pro" & @CRLF & _
"iPhone 6S Plus" & @CRLF & _
"OnePlus 5" & @CRLF & _
"Google Pixel 3 XL" & @CRLF & _
"Google Pixel 3a" & @CRLF & _
"iPhone 12" & @CRLF & _
"Samsung Galaxy Note 10" & @CRLF & _
"Samsung Galaxy Tab S3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")