re = /((?<=Project )\d{0,2}).*?(FOAH|PRJ)(\d{1,10})/i
str = 'C:\\temp\\TimeSheet\\11-06-2017.txt:1:11/06/2017 18:45:56 - This 15 minutes is dedicated to PROJECT 100 FOAH18
C:\\temp\\TimeSheet\\11-06-2017.txt:2:11/06/2017 18:45:58 - This 15 minutes is dedicated to PROJECT 90 FOAH278
C:\\temp\\TimeSheet\\11-06-2017.txt:3:11/06/2017 18:45:59 - This 15 minutes is dedicated to PROJECT 80 FOAH313
C:\\temp\\TimeSheet\\11-06-2017.txt:4:11/06/2017 18:46:00 - This 15 minutes is dedicated to PROJECT 70 PRJ0031905
C:\\temp\\TimeSheet\\11-06-2017.txt:5:11/06/2017 18:46:02 - This 15 minutes is dedicated to PROJECT 60 PRJ0031909 C:\\temp\\TimeSheet\\11-06-2017.txt:6:11/06/2017 18:46:03 - This 15 minutes is dedicated to PROJECT 50 PRJ0032045'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end