package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)({.*})`)
var str = `{
'a': 'B',
'b' : { 'c': 'C' }
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}