#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s-i)(<User>\s*USER_NAME\s*<\/User>.*?<Password>\s*)(\S+)(\s*<\/Password>)"
Local $sString = " <Connection type="Teradata" autoCommit="True">" & @CRLF & _
" <Path>Teradata\BEDW - USER_NAME1</Path>" & @CRLF & _
" <AutoConnect>False</AutoConnect>" & @CRLF & _
" <DefaultOnStartup>False</DefaultOnStartup>" & @CRLF & _
" <Database>" & @CRLF & _
" </Database>" & @CRLF & _
" <Host>teraprd2.ca.host.com</Host>" & @CRLF & _
" <User>USER_NAME1</User>" & @CRLF & _
" <Category>F00000FF:Production</Category>" & @CRLF & _
" <Password>ENCRYPTED_PWD1</Password>" & @CRLF & _
" <WinAuth>False</WinAuth>" & @CRLF & _
" <LastConnectionDate>2019-09-11T16:32:09.1945969</LastConnectionDate>" & @CRLF & _
" <SessionMode>Teradata</SessionMode>" & @CRLF & _
" <SessionCharacterSet>UTF16</SessionCharacterSet>" & @CRLF & _
" <PortNumber>1025</PortNumber>" & @CRLF & _
" <DataEncryption>False</DataEncryption>" & @CRLF & _
" <ResponseBufferSize>1040000</ResponseBufferSize>" & @CRLF & _
" </Connection>" & @CRLF & _
" </Connections>" & @CRLF & _
" <Groups />" & @CRLF & _
"</Group>" & @CRLF & _
"<Group name="EFBI - USER_NAME" description="">" & @CRLF & _
" <Path>Teradata</Path>" & @CRLF & _
" <Connections>" & @CRLF & _
" <Connection type="Teradata" autoCommit="True">" & @CRLF & _
" <Name>USER_NAME @TERADEVL (EFBI_DEV1_USAGE_METRICS_B)</Name>" & @CRLF & _
" <Path>Teradata\EFBI - USER_NAME</Path>" & @CRLF & _
" <AutoConnect>False</AutoConnect>" & @CRLF & _
" <DefaultOnStartup>False</DefaultOnStartup>" & @CRLF & _
" <Database>EFBI_DEV1_USAGE_METRICS_B</Database>" & @CRLF & _
" <Host>teradevl.ca.host.com</Host>" & @CRLF & _
" <User>USER_NAME</User>" & @CRLF & _
" <Category>BCCF87FF:Development</Category>" & @CRLF & _
" <Password>ENCRYPTED_PWD2</Password>" & @CRLF & _
" <WinAuth>False</WinAuth>" & @CRLF & _
" <LastConnectionDate>2019-04-30T15:41:31.3601044</LastConnectionDate>" & @CRLF & _
" <SessionMode>Teradata</SessionMode>" & @CRLF & _
" <SessionCharacterSet>UTF16</SessionCharacterSet>" & @CRLF & _
" <PortNumber>1025</PortNumber>" & @CRLF & _
" <DataEncryption>False</DataEncryption>" & @CRLF & _
" <DefaultDatabase>EFBI_DEV1_USAGE_METRICS_B</DefaultDatabase>" & @CRLF & _
" <ResponseBufferSize>1040000</ResponseBufferSize>" & @CRLF & _
" </Connection>" & @CRLF & _
""
Local $sSubst = "$1(NEW_ENCRYPTED_PWD)$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)