using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)";
string input = @"
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}