package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`$-`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Nullam sit amet neque vitae mi lobortis bibendum luctus at orci.
Maecenas sit amet felis ultrices, imperdiet nibh et, laoreet nisl.
Etiam nec ligula ac quam cursus rhoncus.
Duis ac purus id massa malesuada dapibus.
Quisque tempor sapien sit amet blandit interdum.
Sed sed libero non enim posuere pretium.
Cras in nisl sed magna vestibulum ultrices.
Sed eget neque sodales, porttitor magna nec, facilisis dolor.
Donec venenatis tortor nec leo viverra, non fermentum nulla pulvinar.
Pellentesque a nulla laoreet, euismod lectus vel, porta erat.
Fusce at justo in massa blandit lacinia nec maximus nulla.
Nam vulputate risus et sem facilisis lobortis.
Integer vel risus et enim tempor iaculis.
Pellentesque at nibh in ipsum sagittis congue.
Nam ullamcorper nibh sit amet felis bibendum, congue tincidunt nibh cursus.
Sed eget massa et erat pulvinar aliquet.
Proin congue enim eget turpis blandit, quis tempus nulla venenatis.
Proin iaculis lorem eget elit efficitur, accumsan ornare lacus commodo.
Vivamus mollis orci et erat dignissim rhoncus.
Cras at arcu ac ligula interdum dictum non at nisl.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}