re = /^(?!.*SNAPSHOT).*$/m
str = 'SNAPSHOT
SNAPSHOT.01.1
102.1.1.SNAPSHOT.ra
aaaa
dfadfa
dccc
ccccc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end