$re = '/^(?:(?:[1-9]\d*|0)?(?:[.]\d+)?|MY STRING)?$/m';
$str = 'MY STRING
1.4566
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);