#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<!\d)\d{16}(?!\d)|(?<!\d[ _-])(?<!\d)\d{4}(?:[_ -]\d{4}){3}(?![_ -]?\d)"
Local $sString = "1234123412341234" & @CRLF & _
" (16 digits all together)" & @CRLF & _
"" & @CRLF & _
"1234 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"1234-1234-1234-1234" & @CRLF & _
"(card numbers with hyphens and spaces)" & @CRLF & _
"" & @CRLF & _
"Find me 1234-1234-1234-1234 Find me (card numbers hidden amongst text)" & @CRLF & _
"" & @CRLF & _
"What I'm struggling to stop is the false positives I get, which I know are a direct result of achieving result number 4 above. The false positives being more than 16 digits which are clearly not card numbers. E.g" & @CRLF & _
"" & @CRLF & _
"1) 1234-1234-1234-1234-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")