import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([rnbqkp1-8]+\\/){7}([rnbqkp1-8]+) [bw] (-|KQ?k?q?|K?Qk?q?|K?Q?kq?|K?Q?k?q) (-|[a-h][36]) \\d+ \\d+";
final String string = "7P/2P1b3/2r5/2r2p2/pk6/3B2p1/3K1P2/8 b Qk - 7 234\n"
+ "7n/N4pp1/3n4/3K4/2r5/1Q6/2RbB2P/P7 b Kkq - 6 64\n"
+ "8/8/1n6/3r1P2/6P1/3P3P/8/8 b Kk c3 19 224\n"
+ "8/p1P4P/1p1p2K1/3P2B1/5P2/R6p/k5P1/3P4 w Kk - 4 203\n"
+ "2n5/4q3/3rN3/2p2P1Q/2P2P2/N2P4/4p3/B2B2P1 w Q - 24 136\n"
+ "8/1P1Qp2q/1p1k3R/1n5P/bPp4P/n7/pp2B3/5p2 b KQ c6 3 206\n"
+ "8/4b3/2k5/1p1K4/B5n1/8/7P/3Q4 w Kq - 7 191\n"
+ "6P1/3p4/1Pp2k2/K2P4/1r1q1n1B/1Q4P1/4pP1b/2P5 w - b3 36 224\n"
+ "2k5/8/4P3/2P1Q3/2bP3p/8/N6K/1pP2p1N b Kq - 16 71\n"
+ "1k6/2PB1q2/2Prp2p/p3Q3/6P1/3P4/6p1/Pp4B1 w kq b3 48 189\n"
+ "1P6/3B4/pN2P3/6P1/B1P2Nk1/7b/8/8 w KQk e3 36 39\n"
+ "3k3q/5p2/1RN5/6N1/5P2/1r5b/8/2nB4 b Kk a3 11 87\n"
+ "8/4P3/p2P3p/8/1p4N1/5br1/5p2/B6p b Kk h6 45 36\n"
+ "8/8/2p2b2/1P4P1/4n3/8/2P3R1/8 w KQ g6 26 73\n"
+ "5p2/p5P1/1n6/8/8/2p1N3/8/3pr3 w KQkq f6 25 210\n"
+ "2p5/P5pp/3P4/2Pp3p/2Pp4/5P2/2P5/1q1Kk1b1 b KQkq - 25 14\n"
+ "1NPp1kPr/Kpb5/3P2q1/1N2B3/8/8/P7/Q1n1p1P1 b Kkq - 24 254\n"
+ "Q7/P7/4n3/4NR2/1p2K3/8/4B3/5r2 b KQq - 9 111\n"
+ "6bP/n7/3P3P/3p3n/5p2/B7/4P3/2N5 b KQq d6 11 234\n"
+ "1P3Q2/P5b1/3p1p1r/1p3NK1/5R2/4p3/8/8 b Kk f3 38 250\n"
+ "p7/8/4R2p/8/8/4P3/4pn2/p2rNb1P w q - 34 263\n"
+ "7P/8/3B1P1p/1P1K4/p7/R7/7P/1p2r3 b Qq - 35 24\n"
+ "1K2P1N1/1n3p2/1k1pP1b1/2p1b2B/5R2/8/3P1B1q/1r1P4 w KQ c6 23 200\n"
+ "1Rbb2Pp/2p3p1/8/5R2/3p3p/N7/2q5/P7 w q - 7 240\n"
+ "8/1N1pn1K1/1p1P1Q2/8/1b1Rp3/1k3r2/P6p/8 w Q a6 29 26\n"
+ "P6P/4n3/rN1p1k2/4P1R1/p3P3/3b1K2/p2q4/1pBp4 b Qkq c6 36 162\n"
+ "8/R1P4P/B7/7p/4B3/4p2P/N5P1/3Pr3 b KQ - 27 177\n"
+ "8/1q2R3/2p5/2N5/8/P3Pr2/4rB1p/7p w Qq - 2 50\n"
+ "8/3k4/8/8/P3P3/1BP2p2/2p1N3/4n3 w Qkq f3 43 48\n"
+ "3p4/pP6/3n3p/1N2P3/Q6N/2k4p/1B4K1/8 b q f3 17 267\n"
+ "7P/r5n1/3P4/7b/8/3P4/4P2P/8 w Kk - 35 33\n"
+ "4p3/1PP2r2/7R/1Q1P4/b7/4R3/pp2NPn1/2p1BK1N w - - 1 226\n"
+ "4n3/P5bN/4P1P1/4R2P/B3pp2/1P6/5k2/4K3 w KQkq - 16 2\n"
+ "5p2/8/1B6/p3n3/1K1p1PR1/4P3/8/2B5 w Qq - 20 83\n"
+ "p7/7P/1R6/7p/2p2p2/1Pqn1P2/2Pp3K/5B2 w Kk a6 42 21\n"
+ "2k1PPb1/2N5/5P2/Q1P1nK2/6R1/2r1RB1p/2P5/8 w kq a6 18 230\n"
+ "1P6/K7/P7/3n2r1/p3N3/Rp2P3/8/4p3 w Kq - 23 121\n"
+ "1Rbq2N1/3N4/1Q1P4/6P1/4kP2/3P4/Pp3n2/B1P1p2K b KQ c3 10 176\n"
+ "8/5pn1/6p1/8/7p/5K1p/P2p3p/q3k2b w Kq - 11 99\n"
+ "4nN2/8/1pR1K3/5p2/1np5/R7/5p2/3r2b1 b Kq - 14 201\n"
+ "R7/5k2/3P1P2/7p/B7/5n2/Np5p/r7 w KQk h6 41 190\n"
+ "6B1/5P2/3R4/8/1p6/3P4/8/P4bp1 w Qq - 19 30\n"
+ "1Q1PP3/1pp1P1r1/p2N3N/1p3q1r/8/8/4n3/2RP4 w kq - 0 68\n"
+ "3PQ3/P3qk2/1n1pP3/4K3/3P4/8/2PN4/p2P4 b KQq a3 42 138\n"
+ "1Q1p1P2/b7/r3P3/1p6/2B1N2P/1p6/3q4/1r6 w Qk a3 29 235\n"
+ "4N3/5R2/PpQ5/1p4k1/7B/1n6/8/4b3 b kq b6 40 162\n"
+ "p6P/8/2P5/7r/2p5/b1B2P2/1r1P4/8 w - e3 20 4\n"
+ "2B5/kQ6/5br1/8/7P/8/1R2P1n1/4rqp1 b Qk - 15 67\n"
+ "2P1bp1P/2b2P2/2P2BRK/2r4n/2N3P1/2R5/1N4k1/4p3 b q g3 17 152\n"
+ "8/n1p1p3/1P1k4/R1n5/7r/1P6/B7/2p1PPB1 b KQq - 24 17\n"
+ "1b6/4P3/nq2p2B/2b4K/6r1/4R1p1/P2pp2P/2PP3p w - b6 27 254\n"
+ "n3p3/5p2/8/7P/8/3B3N/8/P1N5 b - - 1 234\n"
+ "8/2b5/6n1/pNB3np/1P6/8/1B2q3/P6P b Qk g3 5 63\n"
+ "1p1PPRn1/N1R2K2/1P1q4/4pp2/3P2B1/8/2p2Ppr/p7 w KQk c6 26 174\n"
+ "2p5/6pB/8/n7/P5N1/8/R1NQ1P2/4b3 w - - 46 171\n"
+ "8/p7/4p3/3nKp2/1q4P1/3r1b2/1p6/B1Q1B3 w KQk a6 17 52\n"
+ "6pP/2B5/1qn5/5pP1/1K1Q3p/R6b/2pr1PRk/8 w Kkq d3 23 96\n"
+ "3kN2Q/5p2/2K5/4nBb1/4P1p1/4q1P1/n2b1p1R/8 w Kk - 36 146\n"
+ "3pR3/5N2/p7/2PbpppP/8/1Q3q2/4RB2/5PP1 b k f6 47 60\n"
+ "n5k1/1r2P3/8/8/PR1P4/8/2b5/8 b - a6 14 238\n"
+ "2P5/5N1P/1Q6/4B3/3n3P/B4p2/8/1P3P2 b Qk - 32 166\n"
+ "8/8/P3KP2/4R3/8/r7/b4P2/2N2r2 w Q - 3 251\n"
+ "8/Q6N/1P6/1P2b3/8/3P1pr1/1nB4R/4P2r b Q e3 31 33\n"
+ "P1B4N/2p3Rq/K1b3p1/4b1p1/P4n1k/2r2P2/5n2/4p3 b k b6 24 168\n"
+ "8/8/1p1PP2b/6B1/p2Pp2Q/5P2/2P5/1Nk2R2 w - c6 46 258\n"
+ "Q1P3p1/1n4N1/8/3B3P/7p/PP6/5bP1/8 b Kq h6 24 240\n"
+ "1N6/2PK1pP1/1p6/4P1rk/p5Bp/P1P4B/4p1P1/8 b - - 19 146\n"
+ "Pp6/4P3/pr3b2/2N5/2K2P2/8/1n5n/8 b Kkq - 35 192\n"
+ "3Qp3/8/4R3/8/8/2r1P1Pr/1bP3p1/8 b kq b3 40 159\n"
+ "4N2r/7N/P3Bb1B/QP1p4/PPnP4/1P2P3/R3npqP/1p6 b KQk - 41 239\n"
+ "8/4Pp2/2k5/b1N4P/2P2rn1/B7/p1p1p1P1/4P2N b K f3 47 218\n"
+ "4p3/8/1P2B3/6b1/8/3rQ3/2pb4/P3p3 b k - 40 36\n"
+ "1k4r1/2pP2rp/1p3P2/4p3/1p6/7K/1N4P1/B1Nb1P1p w Kk - 41 224\n"
+ "4P2R/1p1N1qB1/8/3P4/8/4p3/8/7P b Qk - 11 48\n"
+ "k7/Np1P4/p1b1K3/3P1r2/P7/8/B7/4RpnP w q - 21 260\n"
+ "P3RP2/p7/1B6/2p5/rB6/Pk6/3pp3/p4Q2 w KQkq e6 25 134\n"
+ "B7/1P4r1/5q2/p1P5/p7/P3Npn1/2R4k/5B1P w k - 5 253\n"
+ "6n1/q7/8/2rp4/2Np4/NP1R4/3p4/2p5 b KQ a6 18 261\n"
+ "8/2B1qR2/1QP5/3P4/1P3P2/1R3p2/4r1PP/1r2p2B b kq e6 8 238\n"
+ "8/6PR/8/2N5/2p1p2p/1npR3p/1B6/K7 b Q h6 1 23\n"
+ "2B5/p5P1/2Q5/2KN4/P4q2/5p1n/2p3R1/6p1 b k - 20 265\n"
+ "3p2p1/8/3b4/3kp3/8/7N/r6p/1r1P4 w kq - 8 100\n"
+ "2p1R3/8/4prpR/8/nkN5/2P5/5B1n/7P w q b6 37 136\n"
+ "6nb/Q2PP3/p3Pp2/2r5/4P3/8/4p1r1/8 w K - 31 141\n"
+ "6p1/3n1k1Q/4q3/3P4/3N4/1P1p3b/r7/2P3B1 b K g3 19 229\n"
+ "3n4/2pP1N1p/2pPq1R1/p7/2KP4/8/7R/6P1 b K g6 2 176\n"
+ "P2p4/2K4P/3p2n1/p7/3R1P2/Q6P/2r1p1B1/1Rkp4 b KQ d6 17 116\n"
+ "4Pp2/n2P2b1/3BkR2/P7/6p1/b7/3P1n1Q/2P5 w q e6 35 198\n"
+ "3p4/2P5/7P/8/1R5N/7q/4Pp2/P7 w Kk b3 47 99\n"
+ "P7/P7/8/4n1kR/4n3/8/7q/4N1pP b Qk - 7 71\n"
+ "4r3/4Bpp1/7q/2KP1B2/3R1p1p/1N1p4/4P3/8 b - - 32 64\n"
+ "3p2pr/P7/8/3P3b/4pk1p/1P6/8/1q1P2P1 w Qkq a6 2 228\n"
+ "p1P2bp1/N2K4/7B/1P3r2/P6k/8/1P6/6p1 b KQq a6 0 222\n"
+ "5R2/b4pp1/8/3N3P/3B2nB/p7/4p3/8 w kq - 13 229\n"
+ "2k1P1p1/5b2/3B4/1n1P1PRp/p4BP1/1q6/p2nQ3/8 w kq d3 36 11\n"
+ "3bpB2/2bN4/6rQ/2N5/KR6/5p2/3k4/8 b K b6 35 103\n"
+ "7B/p2n4/8/3P4/8/3p4/1p6/5r2 w Kk - 17 22\n"
+ "4B3/Nr6/4P3/8/1B6/1b3p2/3p4/2PQP3 b k e6 43 81\n"
+ "k3P3/r7/4N1PP/3B1p2/Q3r3/8/2p3P1/3p4 w KQk - 26 39\n"
+ "PP5r/8/n2K4/8/p2Q4/5b2/4p2N/4N3 b Kkq - 33 171\n"
+ "1P6/3PRp2/1P5p/5pP1/4b2P/1B1k4/2N2p2/8 b Kq d6 38 163\n"
+ "8/1K6/3bN2P/8/Pp6/8/5Np1/3r2k1 b Kkq f6 48 115\n"
+ "2p2P2/b6n/8/1p6/4P3/8/8/2pq1r2 b KQkq e3 31 174\n"
+ "6pR/r1n5/P4P1b/1kN1NP1p/3p1qpP/3r4/1R5b/B1p5 b KQ a6 39 225\n"
+ "P7/2P5/r4K2/P3P3/4P1b1/1B5p/8/r7 b k e6 7 59\n"
+ "pNp5/1n2Pr2/2N5/P7/6b1/5Pp1/R1bp4/8 b Q e6 11 203\n"
+ "3P1pR1/3pp3/Pp6/r1b2K1Q/3pnP2/5B2/2P2r2/1N6 w Kq h3 4 12\n"
+ "q1pk4/3P2NP/4P1P1/1pQR2K1/P1bp4/3NB2n/8/p2P4 b KQq c3 19 165\n"
+ "1P3p2/6B1/8/p5p1/2R3K1/1b6/PP6/Q1P1NP2 b KQq e6 17 10\n"
+ "6np/6R1/5bp1/8/PRr5/2PP1P2/N1p3p1/8 w q - 14 234\n"
+ "8/8/8/8/5N2/3R4/5P2/p3NP1P w Kkq - 24 110\n"
+ "5N2/p7/2P5/6p1/8/Nr1R3p/q4b2/3p3r w KQk g6 25 223\n"
+ "2KB3p/r7/P2pPn2/P3R3/6n1/2r3p1/8/8 w - d6 16 114\n"
+ "7P/2n2p2/4p1b1/P3PN2/3p2p1/nr6/3r4/7p b KQq f3 33 42\n"
+ "4p3/6p1/8/P6r/5bn1/p7/4P3/2p1Q1k1 b q g6 26 132\n"
+ "8/7N/1pp4p/5R2/8/8/k3P1P1/3P4 w KQk g3 21 220\n"
+ "6r1/3p4/R1b1pp1p/1P1P2pp/p1q5/2P5/8/Pp1Q4 w kq - 36 146\n"
+ "8/8/7N/8/2Kr4/8/4n1p1/2nP4 b Kq f3 19 170\n"
+ "3r4/2PP3R/3P3b/1P6/3B2p1/7R/2np4/3Nb3 w Qkq h3 29 142\n"
+ "P3Pb2/8/2r5/8/2B2k2/6Pp/3p4/4p2R b - d6 1 181\n"
+ "P2NP3/8/5R2/8/1n6/P1p4p/2k5/5Q2 w q - 16 152\n"
+ "4p3/4B3/7k/K1p2p2/8/3R4/2b5/P7 w KQ b3 45 183\n"
+ "1P4r1/5p2/3N4/4p3/5PP1/P2RK3/3P1q1p/8 b KQq - 2 82\n"
+ "1pB1P2P/5Pp1/k4p2/1Nr5/2b3K1/2BPn3/8/1P3Q1P b KQkq - 29 180\n"
+ "8/1P6/2p1pb2/r3r2P/8/4N1P1/1pB5/2nRpN1P b Kk c3 21 81\n"
+ "Q7/P7/7P/4NP2/8/3p3r/7P/1p1R1nP1 b Kk h3 0 215\n"
+ "8/q1n4r/RN6/p4p2/5b2/1p2N2P/5rp1/1pQ3K1 b Kk - 23 105\n"
+ "3r1P2/8/p2P3Q/2PR2b1/p7/5NRp/3b3p/2K5 b K - 8 160\n"
+ "1K1r4/4P3/8/3R4/1p2R3/1ppPP3/8/5P2 b K - 6 234\n"
+ "5P2/P2p2B1/1P2p3/4Q3/Pn6/6b1/7p/K7 b q g6 15 252\n"
+ "4P3/2N5/P6N/8/8/3P4/1P1K1p2/2p5 w - - 48 47\n"
+ "7P/1Nq5/6p1/4p3/1R6/3Q4/p1K5/2b5 w K g3 48 257\n"
+ "1P6/8/6Pp/8/1PnP1rP1/8/4r3/6p1 b Kk - 42 42\n"
+ "3p2n1/5K2/8/1bP5/7p/6RN/3R4/1p4N1 b Kq - 28 117\n"
+ "8/4N3/8/2r5/8/P7/2pkn2P/8 w kq - 8 107\n"
+ "6B1/2P5/8/7P/2p2N2/P7/2q4p/8 w Qq f3 39 260\n"
+ "6Pk/1p6/n7/8/4p1P1/1nR5/8/5p2 b k - 42 181\n"
+ "4p3/1P6/2PBp3/5k2/3R4/Q7/1pPB4/7P b Q h6 24 239\n"
+ "8/pP2K3/PnP1p2p/4n1B1/p3PP1p/1q1r4/7P/R4P2 w KQkq a6 13 6\n"
+ "2n1p3/1pP3Q1/8/PP6/2q4P/3p1B1B/1N2R2p/3b1Kk1 b q - 32 245\n"
+ "2kp4/pb5B/BN5R/6r1/8/P7/4Pnp1/p2N2p1 b q e6 20 197\n"
+ "2bB4/2b5/N7/1R3PpN/k7/5p2/3P2p1/p1q5 b Kq f6 36 202\n"
+ "8/3Np3/4p1B1/8/5P1p/3P4/p4Q2/2kq4 w Q - 6 165\n"
+ "8/3Bp3/2p5/5p1b/4k2p/8/7P/7p b KQkq g3 16 172\n"
+ "2B5/3rP3/1RRp3Q/3P4/4b1p1/5p1P/4P3/2q1p3 w KQkq - 29 45\n"
+ "1p5p/8/3Nk3/8/3P1nn1/Q7/4Pb2/3R4 b Kq - 13 100\n"
+ "P5p1/5PQ1/N7/qr2R1b1/7b/8/1B2p3/1n6 b Qq - 42 38\n"
+ "2p1p3/1B6/R4r2/4b3/8/4PP2/8/8 b - b6 45 255\n"
+ "2Q1r1k1/6B1/6P1/8/q5R1/8/4r3/1b2p3 w q d6 1 123\n"
+ "p3Kp2/7P/2N1P3/1b2n2P/4P3/8/8/1B5p w KQ - 46 144\n"
+ "K7/8/3p2r1/3N1p2/8/P3krB1/4P3/pP3p2 w KQ - 31 227\n"
+ "6pb/n4P2/2n1R3/8/6p1/r2p4/8/8 w KQkq e6 2 94\n"
+ "8/8/8/PB2N3/3Q4/2p4b/p6n/1pP4P w K - 29 204\n"
+ "2P5/R3BnK1/p4P1P/7r/7P/7p/7n/P7 w Qkq b3 9 97\n"
+ "1p3KP1/P4Pr1/P7/Bp4P1/p1k2p1p/1P6/8/5b2 w KQkq h6 29 153\n"
+ "1p3B2/3Pp3/1p3P2/1q1b3P/8/2n5/P7/p4NR1 b KQk e6 0 180\n"
+ "b7/4r3/3R1N1b/5R2/8/6N1/1p2p3/1p2n3 b KQk c3 4 150\n"
+ "8/3R4/5P2/5p2/B3r1QP/8/5p2/1k6 b - - 42 237\n"
+ "2B2p2/5p2/2p2P2/2p5/P7/3P3P/2QR4/Rp1PN3 w KQ e3 44 44\n"
+ "1P5P/Q4p2/8/4r3/R5P1/1P4p1/3b4/1P2n2p b K d6 47 160\n"
+ "5B2/3P3q/1P2RP1b/4p3/8/3P4/4p2p/6P1 w Kkq - 15 125\n"
+ "p7/P1p2p2/4b3/r1P1P3/N2N4/1p3P2/4BP2/8 w Kq f3 12 21\n"
+ "1r1p2P1/3N4/5Bp1/8/2Bb3K/nP2q3/2b2P2/1p2P3 b Qkq f3 29 248\n"
+ "1rP2p2/r2q4/3P2B1/2b4P/8/7P/8/p3p1n1 b KQq - 23 13\n"
+ "2P5/4B3/5p1N/4P3/pN1k1R2/Rp5r/5PQ1/2P5 b Kq h6 12 197\n"
+ "2R3P1/P1P5/3B4/5n2/3q4/4rp1K/7N/3N1p2 b kq a6 22 70\n"
+ "1r6/8/6K1/6P1/1B6/5PP1/P2pp3/1N6 b Qk e3 26 244\n"
+ "1PpP4/1P5P/p1P1nP2/Rbp5/r2k4/3nrPp1/4N3/8 w KQk h3 29 221\n"
+ "N2prp1p/1Pk1P3/8/7P/1K6/6n1/8/Q3Rp2 w KQ - 48 263\n"
+ "b3R3/P2b4/1P6/8/1N6/3PP3/4p2Q/p6n b Qk - 29 203\n"
+ "B4PRp/3N4/2r5/pP1P1b2/8/8/8/P7 w Q f6 43 242\n"
+ "2p3p1/2B5/k1n2R1R/6p1/P2K4/2P5/1P1PBp2/4P3 b Kk d6 28 248\n"
+ "3p3N/n5k1/b1r5/4P3/3r4/1R6/5Q2/6P1 w - g6 24 200\n"
+ "2P1r1n1/1P4p1/1b6/6PK/2p1p3/N3B3/2P5/Rr6 b KQkq a6 30 61\n"
+ "4P3/8/r1P1RP2/pk2q3/P1n4b/1KQ1N3/1B5p/8 w Qkq - 21 17\n"
+ "6pP/Q3rp2/8/5p2/4P3/4P3/1P2n1R1/2Pp3K b KQk - 40 6\n"
+ "n3p3/6Pp/6R1/3K2N1/6p1/1rP2B2/p5b1/1P1P1p2 b kq d6 23 196\n"
+ "8/P7/7p/2B5/6N1/2P1r3/n2Q4/5N2 w - - 6 95\n"
+ "P1Bb4/2p5/5Q2/8/3p2p1/4B3/4b3/3NK3 w Kkq d6 32 102\n"
+ "3p1pKk/p3p1bP/3n3r/3B4/2N1p3/4PP2/5B2/R4P2 b - - 25 9\n"
+ "1bP3B1/2n1k1N1/5pp1/8/7P/3p1p2/1Q5p/3P4 b KQq f3 34 253\n"
+ "3p1N2/2nr3R/Bk2n3/4P2p/3q3P/R7/2b5/PN2p3 w Kq h6 2 142\n"
+ "8/2Q3P1/8/2P3pp/8/6P1/3PK3/2p1q3 b Kk d3 27 168\n"
+ "6p1/1p3Q2/8/4P3/8/1p6/8/B7 b - - 29 266\n"
+ "8/3N1p1B/8/3pN3/r3p1P1/1P5B/8/q5r1 w KQq d3 21 21\n"
+ "4p3/6RP/3PKk2/1p6/p3BN1r/5N2/3p2qp/b7 b Qkq f3 11 143\n"
+ "5P1p/3r4/1Pk5/1Kp1Q1n1/5P1q/1p6/1P3B1R/3R4 b KQkq a3 12 30\n"
+ "2k1P3/1B6/q6P/6n1/1r1p2Kp/8/8/1R1p2P1 w q - 29 137\n"
+ "8/P2p4/8/5B2/1PP4Q/3N4/pn6/4p1P1 b KQkq h3 12 84\n"
+ "p1P4p/1B6/1P2r3/PP4b1/7R/q4p2/n4N2/7p b Qk f3 30 136\n"
+ "1K1b4/4N3/7Q/8/4p3/2P3P1/rr2pP2/7k b KQk - 32 207\n"
+ "nr3p2/8/5p2/P2P3b/6Pp/8/k7/3Q3R b KQkq - 11 1\n"
+ "2Pp1P1p/2p5/1pb5/6p1/3Q3q/6Nn/7B/6p1 b Kk a6 0 241\n"
+ "1P6/6r1/6p1/2p5/2p2B2/7K/8/1P6 w KQq f3 35 47\n"
+ "8/8/6P1/8/p4Np1/8/Q1N5/1p2B3 b - d6 17 192\n"
+ "2N4P/3r3p/1B4n1/8/2b1P1P1/1K6/1p5r/PQRp4 b Kk - 18 230\n"
+ "1R3p2/5n1P/1P4Qp/2N4p/8/2B4q/4P3/7k b Kkq - 48 147\n"
+ "8/8/8/1PP5/3Q4/6R1/1Bp1PP2/8 w - e3 23 26\n"
+ "4P3/5n2/r2p3p/8/1Rp3N1/8/2p5/K5P1 w KQkq - 27 28\n"
+ "2P5/6P1/P1R5/RP6/3r4/p5bp/4p3/6P1 b Kkq - 17 63";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}