import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d]+)\\.\\s((?:[\\w]+|[\\w]+\\s[\\w]+))\\s(\\d\\.[\\d]+)";
final String string = "612. Grt. Am. Mgt. & Inv. 7.33\n"
+ "77. Wickes 4.61\n"
+ "265. Wang Labs 8.75\n"
+ "9. CrossLand Savings 6.32\n"
+ "228. JPS Textile Group 2.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}