#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<(script|style)((?:(?!src|nonce).)*?)>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html class="no-js" lang="en-US">" & @CRLF & _
"<script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"wpemoji":"https:\/\/localhost:32810\/wp-includes\/js\/wp-emoji.js?ver=5.6-alpha-48683-src","twemoji":"https:\/\/localhost:32810\/wp-includes\/js\/twemoji.js?ver=5.6-alpha-48683-src"}};" & @CRLF & _
"} );</script>" & @CRLF & _
"<style>img.emoji {padding: 0 !important;}</style>" & @CRLF & _
"<style id='twentytwenty-style-inline-css'>.color-accent{ color: #cd2653; }</style>" & @CRLF & _
"<script src='https://localhost:32810/wp-content/themes/twentytwenty/assets/js/index.js?ver=1.5' id='twentytwenty-js-js' async></script>" & @CRLF & _
"<script>document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );</script>" & @CRLF & _
"<style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>" & @CRLF & _
"<style media="print">#wpadminbar { display:none; }</style>" & @CRLF & _
"<style media="screen">html { margin-top: 32px !important; }</style>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<script test>(function() {var request; b[c] = b[c].replace( rcs, ' ' );}());</script>" & @CRLF & _
"<script src='https://localhost:32810/wp-includes/js/hoverintent-js.min.js?ver=2.2.1' id='hoverintent-js-js'></script>" & @CRLF & _
"<script src='https://localhost:32810/wp-includes/js/admin-bar.js?ver=5.6-alpha-48683-src' id='admin-bar-js'></script>" & @CRLF & _
"<script src='https://localhost:32810/wp-includes/js/wp-embed.js?ver=5.6-alpha-48683-src' id='wp-embed-js'></script>" & @CRLF & _
"<script test>var t, e = location.hash.substring(1);</script>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $sSubst = "<$1 nonce="test"$2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)