import Foundation
let pattern = #"PLF2"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import React from 'react';
import { useState } from 'react';
export default function UserForm() {
const [students, setStudents] = useState([
{ id: 1, name: 'Anna', age: 18 },
{ id: 2, name: 'Tom', age: 17 },
]);
const [name, setName] = useState('');
const [age, setAge] = useState(0);
const handleSubmit = (event) => {
event.preventDefault();
};
const newStudent = {
id: Date.now(),
name: name,
age: age,
};
setStudents([...students, newStudent]);
setName('');
setAge(0);
return (
<div>
<ul>
{students.map((student) => (
<li key={student.id}>
{student.name}
{student.age}
</li>
))}
</ul>
<form onSubmit={handleSubmit}>
<input
type="text"
value={name}
onChange={(e) => setName(e.target.value)}
/>
<input
type="number"
value={age}
onChange={(e) => setAge(e.target.value)}
/>
<button type="submit"> Hinzufügen</button>
</form>
;
</div>
);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)