$re = '@<img[^>]+src="\K/@i';
$str = '<p><img alt="Церемония вручения инвентаря в стадионе \'Локомотив\'(Саратов). 5 марта 2020" src="/media/images/news/uploads/mentalsport/IMG_20200311_103008.jpg" /></p>
<p><img alt="Церемония вручения инвентаря в стадионе \'Локомотив\'(Саратов). 5 марта 2020" src="/media/images/news/uploads/mentalsport/IMG_20200311_102923.jpg" /></p>';
$subst = "https://site.ru/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;