import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+(\\+?|\\.?)\\w+\\+?\\w+?)@(\\w+|\\w+\\.\\w{2})\\.com$";
final String string = "tom@hogwarts.com\n"
+ "tom.riddle@hogwarts.com\n"
+ "tom.riddle+regexone@hogwarts.com\n"
+ "tom@hogwarts.eu.com\n"
+ "potter@hogwarts.com\n"
+ "harry@hogwarts.com\n"
+ "hermione+regexone@hogwarts.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}