#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)EXP.*\n(?P<data1>[0-9]+)\n(?P<data2>[0-9]+)\n(?P<data3>[0-9]+)\n(?P<gname>[A-z_0-9]+)\n(?P<gcode>[A-Z]+)\n(?P<gvers>[0-9]+)\n(?P<app_desc>[A-z0-9 ]+)\n(?P<run_desc>[A-z0-9 ]+)\n(?P<last_mod>[A-z0-9: ]+)\n(?P<data4>.*)\n(?P<parent>.*\.(?:APP|app))\n(?P<script>.*\.(?:APP|app))\n(?P<app_type>[A-Z]+)\n(?P<app_vpr>.*\.(?:VPR|vpr))\n"
Local $sString = "&PROJFIL" & @CRLF & _
"EXP0 3 0Node File {CATALOG_DIR}\99_temp\initial_nodes.dbf " & @CRLF & _
"EXP1 1 0Matrix File 1 {CATALOG_DIR}\99_temp\Y{year}_initial_skims.mat " & @CRLF & _
"EXP1 220Network File {CATALOG_DIR}\99_temp\initial_highway_loaded.net " & @CRLF & _
"EXP2 1 0Network File {CATALOG_DIR}\99_temp\checked_pt_network.net " & @CRLF & _
"EXP2 7 0NTLegs File {SCENARIO_DIR}\Y{year}_{NetName}_nt_legs.ntl " & @CRLF & _
"EXP2 130Route File 1 {CATALOG_DIR}\99_temp\initial_PT_skims.rte " & @CRLF & _
"EXP2 230Matrix File 1 {CATALOG_DIR}\\99_temp\initial_PT_costs.mat " & @CRLF & _
"EXP3 1 0Network File {SCENARIO_DIR}\Y{year}_unloaded_network.net " & @CRLF & _
"EXP5 210Record File 1 {CATALOG_DIR}\99_temp\vc_factors.dbf " & @CRLF & _
"EXP5 220Record File 2 {CATALOG_DIR}\99_temp\sector_factors.dbf " & @CRLF & _
"EXP6 1 0Matrix File 1 {SCENARIO_DIR}\Y{year}_{FareScen}_RFARES.mat " & @CRLF & _
"EXP7 4 0Print Data 1 {SCENARIO_DIR}\Y{YEAR}_initial_network_costs_summary.dat " & @CRLF & _
"11" & @CRLF & _
"0" & @CRLF & _
"0" & @CRLF & _
"Network_Builder" & @CRLF & _
"NB" & @CRLF & _
"00" & @CRLF & _
"Network Builder" & @CRLF & _
"Building The Network" & @CRLF & _
"Thu Sep 04 20:35:34 2025" & @CRLF & _
"" & @CRLF & _
"D:\Projects\20240510_Manila_STM\Manila_STM\Manila00.app" & @CRLF & _
"D:\PROJECTS\20240510_MANILA_STM\MANILA_STM\10_NETWORK_BUILDER\NETWOR00.APP" & @CRLF & _
"VOYAGER" & @CRLF & _
"D:\Projects\20240510_Manila_STM\Manila_STM\DEFAULT.VPR" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"Network Building" & @CRLF & _
"29,-8,0,0,Calibri,48,700,0,0,5066061" & @CRLF & _
"2" & @CRLF & _
"TODO: - Add Nodes and Centroids and Centroid Connectors (can be dummy initially) - DONE - Add capability of adding Schemes - DONE - Build Test Highway Assignment for unit Matrix - DONE - check unconnected zones - DONE - Build PT Files (Factors, line, NT Legs, etc) - Working Now, but nee" & @CRLF & _
"d to renumber the network... - Perform initial Skims for first assignment - DONE" & @CRLF & _
"2441,-1563,0,0,Calibri,14,400,0,0,255" & @CRLF & _
"&End_TextAnnotation" & @CRLF & _
"" & @CRLF & _
"{ZoneVersion,ComboList-CHARACTER,"Zone Version for TAZ","BASE", ,"BASE","250506"}" & @CRLF & _
"{Network Schemes,EditBox-CHARACTER,"Network Schemes","schemes_v0.csv"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")