#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d.]+) oz"
Local $sString = "0 Adult Dog Food 18-Count, 3.5 oz Pouches 3.5" & @CRLF & _
"1 Gardetto’s Snack Mix, 1.75 Ounce 1.75" & @CRLF & _
"2 Colgate Whitening Toothpaste, 3 oz Tube 3" & @CRLF & _
"3 Adult Dog Food, 13.2 oz. Cans 24 Pack 13.2" & @CRLF & _
"4 Keratin Hair Spray 2!6 oz 6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")