import Foundation
let pattern = #"^(?:00?|\+)330?|(?!\n)\W"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)