#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\[ERROR\])(.*\n)[\s\S]*?(?=\bBUILD\b)"
Local $sString = "[INFO] " & @CRLF & _
"[ERROR] Tests run: 77, Failures: 0, Errors: 2, Skipped: 0" & @CRLF & _
"[INFO] " & @CRLF & _
"[INFO] ------------------------------------------------------------------------" & @CRLF & _
"[INFO] BUILD FAILURE" & @CRLF & _
"[INFO] ------------------------------------------------------------------------" & @CRLF & _
"[INFO] Total time: 42:09 min" & @CRLF & _
"[INFO] Finished at: 2022-02-25T10:40:21Z" & @CRLF & _
"[INFO] ------------------------------------------------------------------------" & @CRLF & _
"[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:3.0.0-M5:test (default-test) on project ***-***-******-*****: There are test failures." & @CRLF & _
"[ERROR]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")