$re = '/(;|\/\/).*$/m';
$str = ';
//
expr1 ; commen1
expr2 // comment2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);