import re
regex = re.compile(r"^\"*status:([0-9]{1,3}), body:{\"code\":[0-9]{3},\"message\":([0-9a-z\":\/\\\s-_.,]*?),\"errorStack\".*$", flags=re.IGNORECASE)
test_str = ("\"status:400, body:{\"code\":400,\"message\":\"transaction failed:01070333:3: Virtual Server /Common/agc_idp_10.app/agc_idp_10_vs illegally shares destination address, source address, service port, ip-protocol, and vlan with Virtual Server /Common/agc_200.app/agc_200_vs.\",\"errorStack\":[],\"apiError\":2}\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")