$re = '/(\d+(, \d+)+)?/';
$str = '123
123, 230
234, 560, 890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);