#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\w ]+) (is friends with) ([\w ]+)" & @CRLF & _
""
Local $sString = "Jesus is friends with Chuck Norris" & @CRLF & _
"Cindy Crawford is friends with Nicole Kidman" & @CRLF & _
"V is friends with Barack Obama" & @CRLF & _
"Chuck Norris is friends with Barack Obama" & @CRLF & _
"V is friends with François Hollande" & @CRLF & _
"Penelope Cruiz is friends with Tom Cruise" & @CRLF & _
"Nicole Kidman is friends with Tom Cruise" & @CRLF & _
"Katie Holmes is friends with Tom Cruise" & @CRLF & _
"Sim is friends with Lara Croft" & @CRLF & _
"Sim is friends with Chuck Norris" & @CRLF & _
"Lara Croft is friends with V" & @CRLF & _
"Yvette Horner is friends with Sim" & @CRLF & _
"François Hollande is friends with Barack Obama" & @CRLF & _
"Sim is friends with Jesus" & @CRLF & _
"Tom Cruise is friends with Barack Obama" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")