$re = '/\w+(?:-\w+)*(?=\s[A-Z]+\b)/m';
$str = 'Mister Foo BAR is here
Miss Bar-Barz FOO loves cats';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);