import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\G(?!^)|clients_field_)([^-:]*)-";
final String string = "\"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6\": \"info@domain.com\",\n"
+ "\"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b\": \"2017-07-26\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}