$re = '/^(?i)(?=.*[a-z])[a-z\d]+$/m';
$str = '123a
123
abc
abc4
AB12CD34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);