$re = '/(?<=\d)\R+(?=\d)/m';
$str = 'My Number is
0
7
8
9
Come Home';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;