$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\w~@#$%^&+=`|{}:;!.?\""()\[\]-]{8,25}$/m';
$str = 'abc
ABC
123
abc123
ABC123
abcABC123
abcABC123$&#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);