re = /\[(.*)\](?!.*notes\.md)/m
str = '[Item 1](./path/notes.md)
[Item 2](./path)
[Item 3](./path/notes.md)
[Item 4](./path)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end