# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w\d]+\/(\d+)\/\d+\/\d+"
test_str = ("R01/10000304603/000/00 \n"
"2235011: R01/10000304604/000/00\n"
"2235021: R01/10000304605/000/00\n"
"2235031: R01/10000304606/000/00\n"
"2235601: R01/10000304607/000/00\n"
"2235611: R01/10000304608/000/00\n"
"2235621: R01/10000304610/000/00\n"
"2235631: R01/10000304611/000/00\n")
subst = "\\t<\\1>\\n\\t\\t\\2\\t</\\1>\\n</\\4>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.