import re
regex = re.compile(r"(\d{4}.\d{3}.\d{3}) (\S+) (\S+) (\S+) (\S+) (\S+)\n(.+)\nHS\.code: (\S+) Country of origin: (\S+)\nEAN: (\S+)", flags=re.MULTILINE)
test_str = ("\"11 4149.310.025 000 1 37,78 1 37,78\n"
"PISTON\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000141478\n"
"21 0734.401.251 000 4 3,05 1 12,20\n"
"PISTON RING\n"
"HS.code: 73182100 Country of origin: JP\n"
"EAN: 2050000026638\"")
subst = ": $1 $2 $3 $4 $5 $6 $7 $8 $9 $10\\n"
result = regex.sub(subst, test_str)
if result:
print(result)