const regex = /^#\s+(?:yaml-language-server\s*:|\$schema:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#\\s+(?:yaml-language-server\\s*:|\\$schema:)', 'gm')
const str = `# yaml-language-server \$schema= schema.json
# yaml-language-server \$schema: schema.json
# yaml-language-server: \$schema= schema.json
# yaml-language-server: \$schema: schema.json
# \$schema= schema.json
# \$schema: schema.json
# \$schema=schema.json
# \$schema:schema.json`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}