const regex = /(?:^|, *)(?<key>[a-z]+) *= *(?<value>[^\r\n,"]+|"[^\r\n"]+"?)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|, *)(?<key>[a-z]+) *= *(?<value>[^\\r\\n,"]+|"[^\\r\\n"]+"?)', 'gmi')
const str = `Include="All Violations", CheckType=MaxTrans
MetricName = PlacedInstances, PlacedOnly = 1
CheckType=Hold, Include="reg2reg,in2reg,in2out,reg2out"
CheckType=Setup, Include="reg2reg,in2reg,in2out,reg2out`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}