$re = '/[^=]+\s=\s(?<value_v2c>[^=]+)(?:varbind-delimiter|$)/m';
$str = '.1.3.6.1.4.1.6876.4.3.308.0 = INTEGER: 3 varbind-delimiter .1.3.6.1.4.1.6876.4.3.304.0 = STRING: "Gray" varbind-delimiter .1.3.6.1.4.1.6876.4.3.305.0 = STRING: "Red" varbind-delimiter .1.3.6.1.4.1.6876.4.3.306.0 = STRING: "Virtual machine failover may have occurred_ - Event: vSphere HA restarted a virtual machine (20780030) Summary: vSphere HA restarted virtual machine i-13-130213-E3VM on host je22v-p01bvs25.shamrock.local in cluster je22v-p01b Date: 11/24/2021 4:01:07 PM VM: i-13-130213-E3VM Host: je22v-p01bvs25.shamrock.local Resource pool: je22v-p01b Data center: jp-east-22v Arguments: eventTypeId = com.vmware.vc.ha.VmRestartedByHAEvent objectId = vm-147534 objectName = i-13-130213-E3VM severity = warning " varbind-delimiter .1.3.6.1.4.1.6876.4.3.307.0 = STRING: "i-13-130213-E3VM"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);