use strict;
my $str = '-----------------------------------------------------------------------------
Product ID : TXSKJI1123321
Quantity : 19
Item : Jeans
-----------------------------------------------------------------------------
NEXT ACTIONS
IF Stock less than 10
Then increase stock for TXSKJI1123321 up to 100 units
Else
No action needed
-----------------------------------------------------------------------------
Product ID : AKSP2790173332
Quantity : 7
Item : Shirts
-----------------------------------------------------------------------------
NEXT ACTIONS
Increase stock for AKSP2790173332 up to 50 units
-----------------------------------------------------------------------------
Product ID: AKSP27901733789
Quantity : 2
Item : Vest
-----------------------------------------------------------------------------
NEXT ACTIONS
Increase stock for AKSP27901733789 up to 15 units';
my $regex = qr/Product ID\s*:\s*(?<PRODUCTID>\w+)\s*Quantity\s*:\s*(?<QUANTITY>\w+)\s*Item\s*:\s*(?<ITEM>\w+)[\s\S]*?NEXT\s*ACTIONS\s*(?<NEXTACTIONS>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}