use strict;
my $str = '?tn_cid=280&tn_fk_specifications_planten_planttype=Groene%20kamer+planten|hangplanten|tuinplanten&tn_fk_ae-waterbehoefte=Weinig%20(2x%20per%20maand)&tn_fk_specifications_planten_plantheight=30%20-%2035%20cm&tn_fk_ae-hoogte-plant=Kleine%20planten%20(tot%2040%20cm)&tn_fk_ae-prijs=16.99-16.99';
my $regex = qr/(?:[\?&][\w-]+=[\w=.|()+%-]+)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}