package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<command>^\w+)|(^|\s)(?<code>[^ ]*)+`)
var str = `xcopy C:\test D:\target\backup\files C:\aaa D:\target\backup\bbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}