#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)date_modified(?<date_modified>.*?)internal_id(?<internal_id>.*?)task(?<task>.*?)priority(?<priority>.*?)status(?<status>.*?)task_status(?<task_status>.*?)created(?<created>.*?)assigned(?<assigned>.*?)date_created(?<date_created>.*?)date_started(?<date_started>.*?)date_due(?<date_due>.*?)date_completed(?<date_completed>.*?)bunit(?<bunit>.*?)task_vendor(?<task_vendor>.*?)task_category(?<task_category>.*?)customer(?<customer>.*?)cust_name(?<cust_name>.*?)cust_territory(?<cust_territory>.*?)contact(?<contact>.*?)time_date(?<time_date>.*?)time_duration(?<time_duration>.*?)comment(?<comment>.*?)opportunity(?<opportunity>.*?)opp_status(?<opp_status>.*?)opp_engineer(?<opp_engineer>.*?)transaction(?<transaction>.*?)yeg_id(?<yeg_id>.*?)Recent Changes"
Local $sString = "date_modified21-DECEMBER-2020 12:25 PMinternal_id313017task2nd Year Annual" & @CRLF & _
"billing pricing -34515priorityMediumstatusCompletedtask_statusAllocatedcreated" & @CRLF & _
"Bernadine PereraassignedBernadine Pereradate_created21-DECEMBER-2020 12:25 PM" & @CRLF & _
"date_started21-DECEMBER-2020date_due21-DECEMBER-2020date_completed" & @CRLF & _
"21-DECEMBER-2020bunitOperationstask_vendorSplunktask_categoryOthercustomer" & @CRLF & _
"cust_namecust_territorycontacttime_datetime_durationcommentopportunityopp_status" & @CRLF & _
"opp_engineertransaction yeg_idRecent Changes" & @CRLF & _
"" & @CRLF & _
"DateSet byContextTypeFieldOld ValueNew Value21-DECEMBER-2020 12:25 PMBernadine" & @CRLF & _
"PereraUISetStart Date21-DECEMBER-2020 12:00 Utc21-DECEMBER-2020 12:25 PM" & @CRLF & _
"Bernadine PereraUISetOwnerBernadine Perera21-DECEMBER-2020 12:25 PMBernadine" & @CRLF & _
"PereraUISetAssignedBernadine Perera21-DECEMBER-2020 12:25 PMBernadine PereraUI" & @CRLF & _
"SetBusiness UnitOperations21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask" & @CRLF & _
"CategoryOther21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask StateAllocated" & @CRLF & _
"21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask VendorSplunk21-DECEMBER-2020" & @CRLF & _
"12:25 PMBernadine PereraUICreateRecordTASK313017You requested to receive an" & @CRLF & _
"email alert for this record. Click here to modify your email alerts" & @CRLF & _
"[https://55349.app.netsuite.com/app/center/userprefs.nl?sc=-29&selectedtab=alerts]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")