re = /((?<Dirctory>\w+)(?=\/))|(?<FileName>\w+)|((?<=\.)(?<FileExtension>\w+))/
str = 'storage/upload/Pictures/Untitledd.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end