$re = '~(?:^(?:\(\w+/\w+\)\h+|[A-Z]+/[A-Z]+\h+)?|\G(?!^))\w+\K/~m';
$str = 'Dogs/Cats
Dogs/Cats/Mice
ANIMALS/SPECIES Dogs/Cats/Mice
(Animals/Species) Dogs/Cats/Mice';
$subst = " or ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;